How to confirm lookup table is being used

tommetcalfe
rasa-nlu

(d booked) #1

Hello,

How can I confirm my lookup table is actually being used in the pipeline? I have tried multiple setups and even tried a pipeline with only the ner_crf but rasa is not detecting entities from my lookup table.

My training_data.md looks like this:

## intent:find_fieldtrial
* Find fieldtrials with [tomatoes](crop) where Proline was used
* Find me fieldtrials in France where Proline was used on a [Sandy Loam](soil_type) soil
* Search for trials with [winter wheat](crop) and high pest severity
* Look for trials with high relative yield
* Find experiments performed in [Loamy Sand](soil_type)
* Load all fieldtrials done in Belgium in 2017

## lookup:soil_type
* Clay
* Silty Clay
* Clay Loam
* Silty Clay Loam
* Sandy Clay
* Sandy Clay Loam
* Loam
* Sandy Loam
* Sand
* Loamy Sand

And my config file:

language: en_core_web_md
pipeline:
- name: "nlp_spacy"
- name: "tokenizer_spacy"
- name: "intent_entity_featurizer_regex"
- name: "intent_featurizer_spacy"
- name: "ner_crf"
  features: [
  ["low", "title", "upper"],
  ["bias", "low", "prefix5", "prefix2", "suffix5", "suffix3",
   "suffix2", "upper", "title", "digit", "pattern"],
  ["low", "title", "upper"]
  ]
- name: "ner_synonyms"
- name: "intent_classifier_sklearn"

Only the entities that are used in the intent training examples are recognized. None of the entities listed in my lookup tables are being recognized. There are no errors while training.


(Libindavis) #2

I am facing the same issue. Hope someone could help us out of this here. Crying…