Giving key error name while training the file

Hi , I am using rasa for faq chatbot . I have generated ,, config.yml, domain.yml, according to the specifications but still while training it gives me following error Training Core model… 2020-02-18 20:10:48 INFO absl - Entry Point [tensor2tensor.envs.tic_tac_toe_env:TicTacToeEnv] registered with id [T2TEnv-TicTacToeEnv-v0] c:\python36\lib\site-packages\gym\envs\ PkgResourcesDeprecationWarning: Parameters to load are deprecated. Call .resolve and .require separately. result = entry_point.load(False) Traceback (most recent call last): File “c:\python36\lib\”, line 193, in run_module_as_main “main”, mod_spec) File “c:\python36\lib\”, line 85, in run_code exec(code, run_globals) File "C:\Python36\Scripts\", line 9, in File "c:\python36\lib\site-packages\", line 76, in main cmdline_arguments.func(cmdline_arguments) File “c:\python36\lib\site-packages\rasa\cli\”, line 76, in train additional_arguments=extract_additional_arguments(args), File “c:\python36\lib\site-packages\rasa\”, line 50, in train additional_arguments=additional_arguments, File “c:\python36\lib\asyncio\”, line 484, in run_until_complete return future.result() File “c:\python36\lib\site-packages\rasa\”, line 101, in train_async additional_arguments, File “c:\python36\lib\site-packages\rasa\”, line 188, in _train_async_internal additional_arguments=additional_arguments, File “c:\python36\lib\site-packages\rasa\”, line 223, in _do_training additional_arguments=additional_arguments, File “c:\python36\lib\site-packages\rasa\”, line 361, in _train_core_with_validated_data additional_arguments=additional_arguments, File “c:\python36\lib\site-packages\rasa\core\”, line 44, in train policies = config.load(policy_config) File “c:\python36\lib\site-packages\rasa\core\”, line 28, in load return PolicyEnsemble.from_dict(config_data) File “c:\python36\lib\site-packages\rasa\core\policies\”, line 298, in from_dict policy_name = policy.pop(“name”) KeyError: ‘name’

My config.yml file

Configuration for Rasa NLU.


language: en pipeline:

  • name: “WhitespaceTokenizer”
  • name: “RegexFeaturizer”
  • name: “CRFEntityExtractor”
  • name: “EntitySynonymMapper”
  • name: “CountVectorsFeaturizer”
  • name: “CountVectorsFeaturizer”
  • name: “EmbeddingIntentClassifier”
  • name: “ResponseSelector”

Configuration for Rasa Core.



  • name: MemoizationPolicy
  • name: KerasPolicy
  • name: MappingPolicy
  • max_history : 1

Could you please help ?

Hey @prapends, welcome to the community. Can you please attach the screenshot of ur config.yml file that will help to understand your issue properly. :blush:

Hi Jitesh, It is resolved now. Done few text editing in It solved the issue…Thanks you anyway :slight_smile:

What editing you did?

I am also getting same error.

Please guide