Getting this error: ValueError: Unknown data format for file ./data/nlu.yml

I use VS Code and using the files there created by the command rasa init + a python file with following code:

from rasa_nlu.training_data import load_data

from rasa_nlu.config import RasaNLUModelConfig

from rasa_nlu.model import Trainer

from rasa_nlu import config

training_data = load_data("./data/nlu.yml")

trainer = Trainer(config.load(“config.yml”))

interpreter = trainer.train(training_data)

model_directory = trainer.persist("./models/nlu", fixed_model_name=“current”)

Please Help me best regards

@R6xDesigns Hello and welcome to the forum!

Are you trying to run the code using Jupyter Notebook? make sure the project tree met the tree structure of rasa.

@R6xDesigns what is your rasa --version ?

Im really new to it so i hope i an answer the question correct.

Im just running in my py env the command py name_of_python_file where the code is in.

my rasa version is 3.0.1 python: 3.8.10 rasa sdk: 3.0.2

@R6xDesigns I will recommend you to please follow this valuable links, so that you get familiar with the rasa and its working. Please start with point 2, as its latest and please while seeing the videos, also see the documents.

Valuable links and resources for your reference

  1. RasaMasterclass
  2. Conversational AI with Rasa - Video Series [Latest]
  3. Rasa for Beginners
  4. Rasa Certification Workshop
  5. Rasa Advanced Custom Actions, Forms, & Responses Workshop No-longer accepting enrolment
  6. Rasa Advanced Deployment Workshop
  7. Rasa Youtube Channel Please subscribe and hit the bell icon for notification.
  8. Rasa Github Mini Project
  9. Rasa Masterclass Handbook
  10. Hardcopy Book : Conversational AI with Rasa

I hope these links will help you to learn Rasa!

I hope this will motivate you a lot and solve your coming issues. Good Luck!

Thx that helped a lot.

Now im relly confused. i tried to make any custom actions in the The basic hello world def that is allready in there worked perfectly. Now i wanted to work with the nlu model interpreter. but if i install vie pip rasa_nlu, i cant start any rasa commands like rasa interactive.

How can that be??

@R6xDesigns congrts Ben, can you please mark this thread as solution and as the nlu model interpreter is not related to the main thread.

But, please share some code or errors for us what you trying to archive now for your next issue. Thanks.