Getting Rasa_nlu.model.UnsupportedModelError:

Getting the below error:

rasa_nlu.model.UnsupportedModelError: The model version is to old to be loaded by this Rasa NLU instance. Either retrain the model, or run withan older version. Model version: 0.0.0 Instance version: 1.0.1

I was able to run this till today morning and by mistake I did pip instal rasa_nlu again and I get this error. I am using only RASA NLU as I just want to know intents and entities, not using rasa core for now.

Please someone help me how to fix this as this on production. Thanks.

Hi @mirzahash,

I guess there are two options:

  1. Install an older version of rasa again:
pip uninstall rasa
pip install rasa==<version of rasa, e.g. 0.15.0a6>
  1. Retrain you model with Rasa 1.0:

In Rasa 1.0 you can still just use NLU, you don’t need to use Core at all. We also have some documentation on that in our new docs: Using NLU Only. The data format did not change, so you should be able to just retrain your NLU model using Rasa 1.0 and use the model afterwards to extract intents and entities. For training an NLU model use the following command:

rasa train nlu -u <path-to-nlu-data>

This will store the trained model in a directory called models. If you want to extract some intents and entities via the command line you can do that with

rasa shell nlu -m models 

Yes, i downgraded rasa-nlu to 0.15.0 and it worked like charm, runs in less than 1s now. Wonder whats wrong with 1.0.1, it takes around 10s.

Is there a python method to import the model?