Getting following error when type rasa x in cmd (need help here)

Starting Rasa X in local mode… :rocket: c:\users\nadeem khan\appdata\local\programs\python\python37\lib\site-packages\rasa\shared\core\slots.py:262: FutureWarning: UnfeaturizedSlot is deprecated and will be removed in Rasa Open Source 3.0. Please change the type and configure the ‘influence_conversation’ flag for slot ‘requested_slot’ instead. category=FutureWarning, The following intents were found in your stories and will be added to the domain: nlu_fallback Traceback (most recent call last): File “c:\users\nadeem khan\appdata\local\programs\python\python37\lib\site-packages\rasa\cli\x.py”, line 454, in run_locally args, project_path, args.data, token=rasa_x_token, config_path=config_path File “c:\users\nadeem khan\appdata\local\programs\python\python37\lib\site-packages\rasax\community\local.py”, line 233, in main _start_event_service() File “c:\users\nadeem khan\appdata\local\programs\python\python37\lib\site-packages\rasax\community\local.py”, line 139, in _start_event_service fn=_event_service, args=(LOCAL_ENDPOINTS_PATH,), daemon=True File “c:\users\nadeem khan\appdata\local\programs\python\python37\lib\site-packages\rasax\community\utils\common.py”, line 855, in run_in_process p.start() File “c:\users\nadeem khan\appdata\local\programs\python\python37\lib\multiprocessing\process.py”, line 112, in start self._popen = self._Popen(self) File “c:\users\nadeem khan\appdata\local\programs\python\python37\lib\multiprocessing\context.py”, line 322, in _Popen return Popen(process_obj) File “c:\users\nadeem khan\appdata\local\programs\python\python37\lib\multiprocessing\popen_spawn_win32.py”, line 89, in init reduction.dump(process_obj, to_child) File “c:\users\nadeem khan\appdata\local\programs\python\python37\lib\multiprocessing\reduction.py”, line 60, in dump ForkingPickler(file, protocol).dump(obj) File “c:\users\nadeem khan\appdata\local\programs\python\python37\lib\multiprocessing\connection.py”, line 949, in reduce_pipe_connection dh = reduction.DupHandle(conn.fileno(), access) File “c:\users\nadeem khan\appdata\local\programs\python\python37\lib\multiprocessing\connection.py”, line 170, in fileno self._check_closed() File “c:\users\nadeem khan\appdata\local\programs\python\python37\lib\multiprocessing\connection.py”, line 136, in _check_closed raise OSError(“handle is closed”) OSError: handle is closed

Sorry, something went wrong (see error above). Make sure to start Rasa X with valid data and valid domain and config files. Please, also check any warnings that popped up. If you need help fixing the issue visit our forum: https://forum.rasa.com/. Traceback (most recent call last): File “”, line 1, in File “c:\users\nadeem khan\appdata\local\programs\python\python37\lib\multiprocessing\spawn.py”, line 105, in spawn_main exitcode = _main(fd) File “c:\users\nadeem khan\appdata\local\programs\python\python37\lib\multiprocessing\spawn.py”, line 115, in _main self = reduction.pickle.load(from_parent) EOFError: Ran out of input

using rasa x as local

rasa shell is running fine. rasa x gives error

@Hamza-Nadeem can you provide what versions you’re using for rasa, rasa-x, and python?

1 Like

Before I was using: Rasa Version : 2.1.3 Rasa SDK Version : 2.1.2 Rasa X Version : 0.34.0 Python Version : 3.7.9

Now I changed the version (given in my previous message) to see the effect, but error is still here

Thank you! While I dig into this issue, have you tried using the quick install method with multipass? This is the recommended method over running locally if running from your personal machine.

I’ll look into it. Thank you @desmarchris :slight_smile:

1 Like

@Hamza-Nadeem sorry for the delay…

This is a bug with the way we disable our telemetry. If you run rasa telemetry enable before running rasa x, it should work. Disabling telemetry using rasa telemetry disable appears to cause this error. We’ll work on a fix so you can run Rasa X without telemetry!

The below one is my requirement. Thought I tried rasa telemetry enable, It doesn’t solve my issue while running rasa x

Screenshot from 2021-03-28 07-48-35

@pitoulambert can you share the full traceback for the error you’re seeing?

@desmarchris There are the screenshots . Thanks in advance

@pitoulambert this looks like a different issue. Are you starting this with a valid Rasa project? If so, I think I’ll need to see the files to see what could be stopping you from running Rasa X. Could you please create a new post with this additional info?

@desmarchris . I found what caused that error . I used end to end user in rules . Actually I want to build my bot both in english and french so I made two actions for the slot set either in english or french .

Below is the story. Want to make it for the rules as well

steps:

  • intent: en_fr entities:
    • langue: English
  • action: action_show_init

steps:

  • intent: en_fr entities:
    • langue: Français
  • action: action_show_init_fr
1 Like

the same errorr after rasa telemetry enable