Feedback on ConveRT Model + Rasa NLU

Hey @arbazkhan971, try installing using the below command:

pip install rasa --upgrade tensorflow && PYTHONIOENCODING=‘UTF8’

Do let me know if this solves your problem.

Hi @arbazkhan971,

are you working with a virtual environment?

However, make sure to use the latest pip Version - otherwise you wont be able to install tf 1.15.

Please do a pip -V or pip3 -V depending on your Setup to make sure.

If the error still occurs I will take a closer look at it after the gym.

Regards Julian

same issue is still persisitent

@JiteshGaikwad @JulianGerhard

Hi @arbazkhan971,

can you please source your env again and try:

pip install

and post the result here?

Regards Julian

still same problem

Hi @arbazkhan971,

okay so let’s try something else. Do you have Python3.6 installed on Ubuntu? If not, please install it, create a new virtualenv by using:

virtualenv -p python3.6 rasaenv

After that, source the env, update pip by using pip install --upgrade pip and try the installation stack again. I know that this seems a bit “over the top” but currently there are lots of different configurations and inter-incompatibilities between libraries and OS and it’s almost in every case better to start clean.

Please post the results here.


same issue I am facing

Hi @arbazkhan971,

can you please post your setuptools and protobuf version? Another user mentioned that updating those might be necessary aswell. You could do that by doing a pip install setuptools protobuf --upgrade.

Regards Julian

If that does not work, I can offer you connecting to your system to investigate the issue. We would do that via ngrok - if you want to.

okay I am ready

tell me the process


okay. Open a terminal and enter:

ngrok tcp 22

You will see something like:

ngrok by @inconshreveable (Ctrl+C to quit) Tunnel Status online
Version 2.0.19/2.0.17
Web Interface [](
Forwarding tcp:// -> localhost:22
Connections ttl opn rt1 rt5 p50 p90
0 0 0.00 0.00 0.00 0.00

I need the address after “Forwarding …” such that I can connect.


Oh I forgot something. Please make sure that sshd runs:

How to enable SSH on Ubuntu


@arbazkhan971 Please share which cloud VM you are using, also python version, pip version. I believe your pip version is older, please upgrade it to v19+.

@arbazkhan971 Upgrade your pip version by using pip install --upgrade pip

i tried this too but still facing same issue

@arbazkhan971 Share your VM detail and cloud provider name. Before upgrading pip, please run sudo apt-get update if you are using ubuntu

Account (Plan: Free)
Version 2.3.35
Region United States (us)
Web Interface
Forwarding -> http://localhost:80
Forwarding -> http://localhost:80

Connections ttl opn rt1 rt5 p50 p90
0 0 0.00 0.00 0.00 0.00