Failed to connect my website to rasa-x server

I followed the tutorial to deploy my rasa-x server on google cloud platform and it was successfull. The problem is i can’t connect my bot to my django app using websocket channel as stated in the example

I keep getting the following error index.js:116 GET net::ERR_CONNECTION_TIMED_OUT index.js:123 Error: xhr poll error at e.exports.onError (index.js:12) at f. (index.js:116) at f.r.emit (index.js:1) at f.onError (index.js:116) at index.js:116

Hi @HermanCeaser, I have the same problem did you solve it. If yes how ?

not yet, still debugging my way through it

Thank for replying, me i am still debugging.

I just updated my rasa-x version to 0.39.3 the “latest” version and also upgraded my rasa version to 2.5.0 to match my custom action server version which was 2.5.0 and :boom: it worked. This is the tutorial i followed :point_down:

I also configured my rasax.nginix.template in nginx-config-files folder to allows CORS from all origins

location ~* \.(eot|ttf|woff|woff2)$ {
    add_header Access-Control-Allow-Origin *;

how to configure nginx-config-files

@HermanCeaser How to do this:

location ~* .(eot|ttf|woff|woff2)$ { add_header Access-Control-Allow-Origin *; }

please @HermanCeaser, help me to fine the nginx-config-files folder.

@Papa, so when you login, navigate to your rasa installation folder then to nginx-config-files

cd /etc/rasa/nginx-config-files/

Then open the rasax.nginx.template file using your favourite editor in my case nano like

nano rasax.nginx.template

add that line at the end of the file before the last closing bracket

thank you

@HermanCeaser hi again, I dit it but it doesn’t work for me. When i do /etc/rasa/ cat .venv I have the following version RASA_X_VERSION=0.39.3 RASA_VERSION=2.4.0 RASA_X_DEMO_VERSION=0.38.0 RASA_TELEMETRY_ENABLED=true REDIS_PASSWORD=4jgvrhTh_uAEc RABBITMQ_PASSWORD=svKTVx6QjEeMx RASA_X_TOKEN=UM1BePmu78CH JWT_SECRET=H5PRrvobfeVSfpMsrchx RASA_TOKEN=gtKiprPKYYEzn DB_PASSWORD=T0pZb13c2zkT do you have the same ?

Try updating the RASA_VERSION to 2.5.0 because i believe RASA_X_VERSION 0.39.3 ain’t compatible with RASA_VERSION 2.4.0. See compatibility matrix here :point_right: Compatibility Matrix

Thank you @HermanCeaser now it works.

Hi @HermanCeaser, i don’t understand how to use the following line in the script of the last version of rasa web chat: ``` window.onload =; (this was use in the chat widget version 0.11.5). I want to open the chat widget on page loading

This is not a problem with your web-browser, but usually it means that there are problems at the client side, such as internet connection issues or an issue with the server where your WordPress site is hosted. ERR_CONNECTION_TIMED_OUT error, or similar, can occur not only with Google Chrome browser , but also, with other web browsers. Rebooting your modem or router generally solves this issue and then you can connect to the website. Try the following simple solutions in the order in which they are listed.

  • Clear Browser Cache
  • Check your Security programs
  • Restart your router
  • Disable Proxy Settings