Errors When Trying To Setup With Docker

Section: Using Docker Compose - https://rasa.com/docs/core/installation

Using: Compose File Example

Tried to setup via online Docker instructions. Used the example docker-compose.yml file data.

When I run it, it blows up with multiple errors. Included a screenshot.

Using Digital Ocean Droplet, Docker Image.

My docker-compose.yml file contents/data from the website documentation.
Run docker-compose up and BOOM… lol Example data below was properly formatted when pasted in here. Not sure why it’s stripping off all the formatting on save. .yml data is not modified in any way. 100% exact image off of the website/docs.

version: ‘3.0’

services: rasa_core: image: rasa/rasa_core:latest networks: [‘rasa-network’] ports: - “5005:5005” volumes: - “./rasa-app-data/models/current/dialogue:/app/model” - “./rasa-app-data/config:/app/config” - “./rasa-app-data/project:/app/project” command: - start - -d - ./model - -c - rest - -u - current/nlu - --endpoints - config/endpoints.yml

action_server: image: rasa/rasa_core_sdk:latest networks: [‘rasa-network’] ports: - “5055:5055” volumes: - “./rasa-app-data/actions:/app/actions”

rasa_nlu: image: rasa/rasa_nlu:latest-full networks: [‘rasa-network’] ports: - “5000:5000” volumes: - “./rasa-app-data/models/:/app/projects” - “./rasa-app-data/logs:/app/logs”

duckling: image: rasa/duckling:latest networks: [‘rasa-network’] ports: - “8000:8000”

networks: {rasa-network: {}}

It looks like it cant find your actions.

If you are in the directory containing you docker-compose.yml are you able to “ls ./rasa-app-data/actions” ?

Did you do step 4 in Building Rasa with Docker ?

Not sure what you mean. If you look at this “main” setup doc and look at the section noted about using docker compose, it says to use that file verbatim. No mention of any other mods. There is no step 4 in this doc. So that section is wrong and/or incomplete?

Using Docker Compose

Rasa provides all components as official Docker images which are continuously updated. To quickly run Rasa Core with other components, you can use the provided docker compose file. This is useful for a quick local setup or if you want to host the Rasa components on cloud services.

Compose File Example ---- What I posted, copied from this section.

Just FYI my other post. I ran into the same issue with the base setup instructions on Ubuntu. They were incorrect/missing info as well. Took me awhile but I did get it running that way. Wanted to setup under Docker. Not surprised at this point if the docs are wrong here as well.

Okay I see the instructions you followed.

If you look at the docker compose files you will see a whole bunch of volumes trying to be shared with the containers. for example …

  • ./rasa-app-data
  • ./rasa-app-data/models/
  • ./rasa-app-data/project

Those files and directories will first have to exist.

I would suggest you follow … Building Rasa with Docker .

Gotcha. So much for the “quick” part of that doc. Thanks for the feedback. I saw the doc you mentioned but the one I was reading seemed to have a current/fast way to set it up and appears to be the main document.

Here is my repository with the hangnman game … GitHub - dadecoza/rasa-hangman: add a game of hangman to your chatbot .

It has a docker-compose.yml and all the required files to start the bot. Just follow the instructions in the README.md. You can then change the nlu and core files to make it do what you want.

Thank you. I will take a look at that. Appreciate the help.