Error when activating rasa server

hi ! , when i run rasa server using this command, --rasa run -m models --enable-api --cors “*” – i got the following error, even though my rasa version is 2.7.1 ------- connect async handler error Traceback (most recent call last): File “c:\users\asus\anaconda3\envs\new_rasa\lib\site-packages\engineio\”, line 449, in _trigger_event ret = await self.handlersevent File “c:\users\asus\anaconda3\envs\new_rasa\lib\site-packages\socketio\”, line 522, in _handle_eio_connect return await self._handle_connect(sid, ‘/’) File “c:\users\asus\anaconda3\envs\new_rasa\lib\site-packages\socketio\”, line 422, in _handle_connect self.environ[sid]) File “c:\users\asus\anaconda3\envs\new_rasa\lib\site-packages\socketio\”, line 504, in _trigger_event ret = await self.handlers[namespace]event TypeError: connect() missing 1 required positional argument: ‘auth’ [2021-07-04 17:05:01 +0200] [15656] [ERROR] Exception occurred while handling uri: ‘http://localhost:5005/’ Traceback (most recent call last): File “c:\users\asus\anaconda3\envs\new_rasa\lib\site-packages\sanic\”, line 931, in handle_request response = await response File “c:\users\asus\anaconda3\envs\new_rasa\lib\site-packages\engineio\”, line 310, in handle_request return await self._make_response(r, environ) File “c:\users\asus\anaconda3\envs\new_rasa\lib\site-packages\engineio\”, line 381, in _make_response response_dict[‘response’], environ) File “c:\users\asus\anaconda3\envs\new_rasa\lib\site-packages\engineio\async_drivers\”, line 104, in make_response status=int(status.split()[0]), headers=headers_dict) TypeError: init() got an unexpected keyword argument ‘body_bytes’ ------- please help !

@rahma can you share the screenshot of error please?

thank you for responding, it kept repeating the same error

@rahma update engineio and socketio

pip install engineio  or pip install python-engineio
pip install socketio 

Then try run and show the screenshot error.

@rahma hope you uncommented in credentials.yml

  user_message_evt: user_uttered
  bot_message_evt: bot_uttered
  session_persistence: true

yes i did uncomment that , another error showed up

by the way i wasn’t able to install socketio not engineio, it showed long errors

@rahma check they are already install while using

pip list

@rahma what is your python version please

python --version and even

rasa --version

Python 3.7.6 image

@rahma install this

pip3 install setuptools or pip install setup tools

python-socketio Version: 4.6.1 python-engineio Version: 3.14.2

requirement already satisfied, version 3.3

@rahma These errors are coming because at the time when you installed Rasa you ignores some compatible issue which display in red color. If not install rasa again on the environment and install all the dependencies.

Tru install rasa

pip install rasa or pip3 install rasa

If some red errors come do share the screenshot please.

hi, yes you were right ! i fixed that issue , now it’s well activated but the web-chat is not working when i deploy it , it shows the following error ! plz help

@rahma Please close this thread as a solution and create the new fresh thread for the web-chat deployment error please. It will create the confusion for other future users. Thanks

feels stupid but how do i close a thread !? :stuck_out_tongue:

@rahma please set as a solution, you see. It’s a best practice so that other users get the solution easily.