Error: 'rasa.graph_components.providers.domain_without_response_provider.DomainWithoutResponsesProvider'

I’m deploying my rasa model in azure kubernetes; everything was working but then I trained a new model (rasa version 3.0.4) and now rasa server tells me that it cannot load my model. The error, after sending a simple message to rasa, is the following:

[INFO ]  Starting Rasa server on
[INFO ]  Loading model models/20220120-111225-cream-trap.tar.gz...
[ERROR]  Could not load model due to Error deserializing graph schema. Can't find class for graph component type 'rasa.graph_components.providers.domain_without_response_provider.DomainWithoutResponsesProvider'..
[INFO ]  Rasa server is up and running.
[INFO ]  Ignoring message as there is no agent to handle it.

What am I doing wrong?

@TalissaDreossi what installation process you have used can you share the link?

I am using a docker image for the pod, if it’s what you are asking me.
The dockerfile is pretty simple:

FROM rasa/rasa:latest
COPY rasa/. .
CMD ["run", "--verbose", "-m", "./app/models/", "--log-file", "/app/models/rasa/log.txt", "--enable-api"]

If I run the model locally it works fine

@TalissaDreossi please share me the all docker file?

That’s my entire dockerfile for rasa server, I have another pod which is the web server sending messages to rasa.

@TalissaDreossi where is your rasa action server image?

@TalissaDreossi Ok please answer these few questions:

  1. You want to install rasa open source using docker? Yes or No?
  2. You want that model also trained using docker? Yes or No?
  3. You also want Web server also run using docker? Yes or No?

oh yes sorry, dockerfile for action server (installed on another pod) is:

FROM rasa/rasa-sdk:latest
USER root   
COPY ./rasa/actions /app/actions
USER 1000

  1. yes, I already have installed it and everything was working fine but then, after retraining and updating the model, the error shows up
  2. no, I train it locally and then upload it in an azure volume
  3. yes, it is also using docker

@TalissaDreossi can you confirm you trained on which version of rasa on the local machine and upload the model on Azure? IS that right?

yes, I trained it locally with both rasa 3.0.4 (and I also tryed with 3.0.0 but it also does not work) and then uploaded it on Azure

@TalissaDreossi local machine rasa version should be equal to docker machine version

For example:

[D] rasa/rasa:2.8.11 == rasa 2.8.11 [LM] train it on LM and then upload the model and run the command.

If am trying what you trying to do here.

1 Like

Thank you! Now it works perfectly :hugs:

@TalissaDreossi No worries :slight_smile: