Error in running rasa with docker

I am getting permission denied error while trying to initialize rasa with docker.

Hm, can you try initializing the bot with rasa init in the working directory, and then moving directly to this step? Running Rasa with Docker

Seems that maybe your docker daemon doesn’t have access to write into your working directory

I tried that too, but got this error

I solved this by running the docker command with the user parameter, i.e.

docker run --user $(id -u):$(id -g) -v $(pwd):/app rasa/rasa init --no-prompt

Note however that I then had the problem that the “models” directory it created in my current working directory was only writable by root, resulting in another permissions error. So I changed the “models” directory’s permissions in my working directory with the chmod command to make it writable by the current non-root user, and ran the above again. It worked and I was then able to run the server.

try to change mode of file. Use:- sudo chmod -R 777 “YOUR FOLDERNAME”

1 Like