Dispatcher.utter_message(response) does not send message on slack

Hi, I’m trying to implement my bot to slack and read everything I could find for my problem but I’m still not able to solve it. I have a custom action that changes something in excel via pandas and xlwings. This action takes longer than 3 seconds so with a normal approach of just executing it, slack will timeout before there is an answer. So i tried to utter a response (‘one second please…’) right after my bot recognizes the intent and after that execute the action with the help of a rule, that tells my bot to:

  • intent: user intent
  • action: utter_response
  • action: call_custom_action

I will receive the message “one second please” and the action will be executed succesfully, the excel file changes as i want to (apart from sometimes not extracting the right entity but that is a problem with my nlu data). At the end of the action i want: dispatcher.utter_message(antwort). Where antwort is a string the action builds along the line. My problem is, that my text just won’t show up in my slack channel. The variable is also not empty as I’m able to print it to my action server via print(antwort). Any guidance on how to solve this would be much appreciated!

The only warning message i get is from the rasa server:

2021-01-19 18:05:43 WARNING rasa.core.channels.slack - Received retry #1 request from slack due to http_timeout.

I don’t know why this is coming up because i thought sending an initial response and then triggering the custom action should avoid the timeout. I’m not even sure if this has something to do with my problem but i thought i might mention it.

Server: rasa run --enable-api --cors * rasa run actions

Versions: rasa 2.2.5 rasa-sdk 2.2.0 python 3.8.5

Attached are my domain, rules, stories, config and relevant custom actions.actions_austaktung.py (10.4 KB) rules.yml (2.1 KB) domain.yml (2.8 KB) config.yml (1.5 KB) stories.yml (5.4 KB)

This issue is resolved…?

@DoubleJu , I was facing this same issue before, my custom action is running MS graph explorer API it’s taking more than 5 seconds, I was minimized that code and tried then it’d working fine, I need to know how to resolve you this issue there any way to increase slack timeout…?