Can not install legacy Rasa anymore

These are official instructions to install
Rasa 2.x

pip3 install rasa


and
Rasa 1.x (Legacy)

pip3 install rasa

yep, what’s the difference, nothing and yes, both will end up in Rasa 2.x version, not in Rasa 1.x and Rasa 2.x which would be the target here

You have to specify specific version for rasa 1 otherwise it will pick up latest version. Probably documentation needs to be updated in legacy.

pip3 install rasa==1.10.16

thanks

I seems that there is no 1.10.16 version, see below

(rasalegacy) linttu@linttu-VirtualBox:~/rasacourse_legacy$ pip install rasa==1.10.16

ERROR: Could not find a version that satisfies the requirement rasa==1.10.16 (from versions: 0.0.1, 0.0.2, 0.0.3, 0.0.4, 0.0.5, 0.1.0, 0.1.1, 0.2.0a2, 0.2.0a3, 0.14.0a5, 0.14.0a6, 0.14.0a7, 0.14.0a8, 0.14.0a9, 0.15.0a6, 1.0.0a1, 1.0.0a2, 1.0.0a3, 1.0.0a4, 1.0.0a5, 1.0.0rc1, 1.0.0rc2, 1.0.0rc3, 1.0.0rc4, 1.0.0rc5, 1.0.0rc6, 1.0.0rc7, 1.0.0rc8, 1.0.0rc9, 1.0.0rc10, 1.0.0rc11, 1.0.0rc12, 1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.4, 1.0.5, 1.0.6, 1.0.7, 1.0.8, 1.0.9, 1.1.0, 1.1.1, 1.1.2, 1.1.3, 1.1.4, 1.1.5, 1.1.6, 1.1.7, 1.1.8, 1.2.0a2, 1.2.0a3, 1.2.0a4, 1.2.0a5, 1.2.0a6, 1.2.0a7, 1.2.0, 1.2.1, 1.2.2, 1.2.3, 1.2.4, 1.2.5, 1.2.6, 1.2.7, 1.2.8, 1.2.9, 1.2.10, 1.2.11, 1.2.12, 1.3.0a1, 1.3.0a2, 1.3.0, 1.3.1a1, 1.3.1a3, 1.3.1a4, 1.3.1a5, 1.3.1a8, 1.3.1a10, 1.3.1a11, 1.3.1a12, 1.3.1a14, 1.3.1, 1.3.2, 1.3.3, 1.3.4, 1.3.6, 1.3.7, 1.3.8, 1.3.9, 1.3.10, 1.4.0, 1.4.1, 1.4.2, 1.4.3, 1.4.4, 1.4.5, 1.4.6, 1.5.0, 1.5.1, 1.5.2, 1.5.3, 1.6.0a1, 1.6.0a2, 1.6.0, 1.6.1, 1.6.2, 1.7.0, 1.7.1, 1.7.2, 1.7.3, 1.7.4, 1.8.0, 1.8.1, 1.8.2, 1.8.3, 1.9.0, 1.9.1, 1.9.2, 1.9.3, 1.9.4, 1.9.5, 1.9.6, 1.9.7, 1.10.0a1, 1.10.0a2, 1.10.0, 1.10.1, 1.10.2, 2.0.0a1, 2.0.0a2, 2.0.0a3, 2.0.0a4, 2.0.0a5, 2.0.0a6, 2.0.0rc1, 2.0.0rc2, 2.0.0rc3, 2.0.0rc4, 2.0.0, 2.0.1, 2.0.2, 2.0.3) ERROR: No matching distribution found for rasa==1.10.16

Then I tried with last 1.x packet what I found on list 1.10.2

(rasalegacy) linttu@linttu-VirtualBox:~/rasacourse_legacy$ pip install rasa==1.10.2

but this ended with error

ERROR: Could not find a version that satisfies the requirement tensorflow-addons<0.8.0,>=0.7.1 (from rasa==1.10.2) (from versions: 0.10.0, 0.11.0, 0.11.1, 0.11.2)
ERROR: No matching distribution found for tensorflow-addons<0.8.0,>=0.7.1 (from rasa==1.10.2)

Can you please share following

  • OS Version (also mention if this is 64 bit or 32 bit)
  • Python version (also mention if this is 64 bit or 32 bit)

make sure you have a compatible Python version . Tensorflow works with only 64 bit Python and that too with Python from 3.5 to 3.8 .

Here is OS info

(rasalegacy) linttu@linttu-VirtualBox:~$ hostnamectl
Static hostname: linttu-VirtualBox
Icon name: computer-vm
Chassis: vm
Machine ID: ae010cd2b70b4a30b1dd130466431509
Boot ID: ad516e8278604dbf932c46b69993475c
Virtualization: oracle
Operating System: Ubuntu 18.04.5 LTS
Kernel: Linux 5.4.0-52-generic
Architecture: x86-64

Here Python info

(rasalegacy) linttu@linttu-VirtualBox:~$ python -c ‘import struct;print( 8 * struct.calcsize(“P”))’
64

(rasalegacy) linttu@linttu-VirtualBox:~$ python -V
Python 3.8.5

I changed python to 3.7.5, now Rasa 1.x is working.
But the installation instructions should be updated ASAP