AttributeError: 'NoneType' object has no attribute 'startswith'

I have set up rasa and created a chatbot however when I access rasa x the payload butttons does not work. I tried rasa x --debug but it gives the error: - An exception occured while handling user message ‘None’. if message.text.startswith(INTENT_MESSAGE_PREFIX): AttributeError: ‘NoneType’ object has no attribute 'startswith

The error is same if I use Rasa Chatroom. If I use rasa shell --debug everything works well without the error.

Hi @rt_ty. Can you please share your domain.yml, config.yml, and NLU training data?

Thanks for your reply. Here are the links to my domain, config and NLU files: domain config NLU

@rt_ty. What versions of Rasa Open Source and Rasa X are you using? How did you deploy Rasa X?

I am using rasa 1.10.2

I believe the error occurs when I click on a payload button in rasa x or chatroom. In rasa x no responds is given other than action listen but if I enter the nlu question directly the bot replies in rasa x.

I have tried to change the slot type or even remove it but still the bot always show action listen

@rt_ty Okay. This sounds like a bug. Can you please report an issue here?

Thanks for the reply, will do just that.

1 Like