Asyncio error while running rasa shell on rasa 3.0

Rasa shell throws out the error. It was working earlier today. One thing, that has changed is , that I started playing around with another (! not the same) conda env and tried to install rasa 3.1 (which did not work and that caused bunch of other problems), but as I understand, this should not impact other envs. Maybe anyone has a clue, why this happens?

2022-05-08 20:55:10 ERROR    asyncio  - Task exception was never retrieved
future: <Task finished name='Task-9' coro=<SignalRouter._dispatch() done, defined at C:\Users\username\anaconda3\envs\rasa_env\lib\site-packages\sanic\> exception=C
lientOSError(22, 'The specified network name is no longer available', None, 64, None)>

Hi @GiedreM,
I was actually encountering simlar issues. I tried to use different Rasa versions on different Anaconda venv, however, they kind of seemed to mix and I broke everything… :grimacing:
I asked about that in the forum here and got the following solution:

instead of conda create -n nameofvenv python==x.x.x, you should use
conda create -n nameofvenv python==x.x.x anaconda.

Maybe that solves your issues?
Ciao, Vio :wave: