API not working for rasa server deployment

Hi everyone,

I was trying to connect to my server deployment via REST API today, but only got 404 errors. I can still connect normally to Rasa X via the browser. Testers seem to have access, too. I tried to troubleshoot via Postman, but also got only 404 errors or no response at all. I was able to connect just fine a couple days ago. I tried ports 5000, 5002, 5005, and 8000. None of them worked.

I had already added to my values.yml file:


Another strange thing I noticed was an error when trying to upgrade the deployment via helm upgrade. The error mentions network policy being an issue, so I am not sure if that might be related.

Error: UPGRADE FAILED: template: rasa-x/templates/network-policy.yaml:2:14: executing “rasa-x/templates/network-policy.yaml” at <.Values.networkPolicy.enabled>: nil pointer evaluating interface {}.enabled

Any help is appreciated!

Did you set rest: in credentials.yml ?

Yes I did. The only thing that solved the issue was purging the helm deployment and upgrading to the newest version. It worked without changing anything in the values.yml and credentials.yml file.