Why rasa truncate spaces in utter message?

I’m trying to give a message with some tabulation to format a table like message, I tryied with tabs, more spaces but seems like rasa render only one space. what I would like to do is something like print("{0:10} {1:30}{2:15}{3}".format(‘first’,‘secont’,‘third’,‘fourth’) +"\r\n" + “{0:10} {1:30}{2:15}{3}”.format(‘first’,‘secont’,‘third’,‘fourth’)) that in python works well but in rasa gave me ognly a simple space you can test it in https://replit.com/languages/python3

Hi, can you clarify where this is happening? Are you trying to format a response from the assistant’s side?

Yes, from custom action.py . for now I solved adding   chars to add spaces

I wasn’t able to replicate this. When I tried:

dispatcher.utter_message("{0:10}{1:30}".format('first', 'second'))

the output was correctly formatted

Screenshot 2021-11-24 at 16.12.42

Can you give more detail on how to replicate this? Are you having conversations using rasa shell?

@fkoerner sorry, I didn’t mentioned that I’m using socket io and website integration, so it cut the spaces in rasa widget