Warning when running embedding policy: Feature 'active_form_xx' could not be found in feature map

2019-02-20 23:22:45 WARNING rasa_core.featurizers - Feature 'active_form_seminar_form' could not be found in feature map.

Hello, I’m getting the above warning when running the embedding policy for a form that asks for details when booking a seminar (location, date).

See one of my sample stories here: failed_story.md (1.3 KB)

Here, I wanted to mimic the flow of the “chitchat stop but continue path” of the rasa example formbot here.

Can anybody spot an error in my file that might cause the above warning?

Thanks!

UPDATE: I tested the formbot example with embedding policy and actually receive the same warnings. I think this should be taken care of.

Hello @tobiwalter. Thanks for raising this. I will look into this and will get back to you.

@Juste any update on this? Thank you

@Juste I also encountered similar problems. I have no problem with Rasa Core training with keras Policy. I have the following problem with embedding Policy. time is a slot and requested_sot in a form

rasa_core.featurizers - Feature ‘entity_time’ could not be found in feature map.

policies:

  • name: EmbeddingPolicy

    epochs: 20

    featurizer:

    • name: FullDialogueTrackerFeaturizer

      state_featurizer:

      • name: LabelTokenizerSingleStateFeaturizer
  • name: FormPolicy

Hey, any news on this? I’m experiencing the same problem as the op. I.e. the Feature 'active_form_xxx_form' could not be found in feature map. I also try to handle the unhappy path in the form as given in the formbot example.

Apparently, I’m getting a similar version to this:

2020-09-13 21:15:36 WARNING rasa.core.featurizers - Feature ‘active_form_form’ could not be found in feature map. 2020-09-13 21:15:36 WARNING rasa.core.featurizers - Feature ‘active_form_form’ could not be found in feature map. 2020-09-13 21:15:36 WARNING rasa.core.featurizers - Feature ‘active_form_form’ could not be found in feature map. 2020-09-13 21:15:36 WARNING rasa.core.featurizers - Feature ‘active_form_form’ could not be found in feature map. 2020-09-13 21:15:36 WARNING rasa.core.featurizers - Feature ‘active_form_form’ could not be found in feature map. 2020-09-13 21:15:36 WARNING rasa.core.featurizers - Feature ‘active_form_form’ could not be found in feature map. 2020-09-13 21:15:36 WARNING rasa.core.featurizers - Feature ‘active_form_form’ could not be found in feature map. 2020-09-13 21:15:36 WARNING rasa.core.featurizers - Feature ‘active_form_form’ could not be found in feature map.

… so many times that my terminal can’t show the full error log.

The example bot from here does not seem to show the same as the official doc here - on github there is a stories.yml file rather than stories.md

But when checking with other people online, I can’t see why I’m getting all these error msgs.

This is my config.yml:

policies:

  • name: MemoizationPolicy max_history: 5
  • name: TEDPolicy max_history: 5 epochs: 100
  • name: MappingPolicy
  • name: FormPolicy

And I don’t have any intent, action or anything that’s called active_form_form.

Has anybody experienced the same recently?

1 Like