# Upgrading rasa I am getting an ERROR: rasa-x 0.33.2 requires rasa==2.0.2, but you'll have rasa 2.1.1 which is incompatible

**URL:** <https://forum.rasa.com/t/upgrading-rasa-i-am-getting-an-error-rasa-x-0-33-2-requires-rasa-2-0-2-but-youll-have-rasa-2-1-1-which-is-incompatible/37448>\
**Category:** \[Deprecated\] Rasa X Community Edition\
**Created:** [November 26, 2020, 3:40pm UTC](https://forum.rasa.com/t/upgrading-rasa-i-am-getting-an-error-rasa-x-0-33-2-requires-rasa-2-0-2-but-youll-have-rasa-2-1-1-which-is-incompatible/37448 "2020-11-26T15:40:47Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![rahultank1993](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.rasa.com/rahultank1993/32/12036_2.png) [@rahultank1993](https://forum.rasa.com/u/rahultank1993)\
**Post date:** [November 26, 2020, 3:40pm UTC](https://forum.rasa.com/t/upgrading-rasa-i-am-getting-an-error-rasa-x-0-33-2-requires-rasa-2-0-2-but-youll-have-rasa-2-1-1-which-is-incompatible/37448/1 "2020-11-26T15:40:47Z")

</div>

Which is the compatible version for rasa 2.1.1 of rasa-x?

I am getting the following error while upgrading rasa.

ERROR: rasa-x 0.33.2 requires rasa==2.0.2, but you’ll have rasa 2.1.1 which is incompatible.

---

<div class="post-metadata">

**Author:** ![ftarlaci](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.rasa.com/ftarlaci/32/11601_2.png) [@ftarlaci](https://forum.rasa.com/u/ftarlaci)\
**Post date:** [November 26, 2020, 5:29pm UTC](https://forum.rasa.com/t/upgrading-rasa-i-am-getting-an-error-rasa-x-0-33-2-requires-rasa-2-0-2-but-youll-have-rasa-2-1-1-which-is-incompatible/37448/2 "2020-11-26T17:29:41Z")

</div>

This might be helpful: [Compatibility Matrix](https://rasa.com/docs/rasa-x/changelog/compatibility-matrix/)

---

<div class="post-metadata">

**Author:** ![rahultank1993](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.rasa.com/rahultank1993/32/12036_2.png) [@rahultank1993](https://forum.rasa.com/u/rahultank1993)\
**Post date:** [December 1, 2020, 2:49pm UTC](https://forum.rasa.com/t/upgrading-rasa-i-am-getting-an-error-rasa-x-0-33-2-requires-rasa-2-0-2-but-youll-have-rasa-2-1-1-which-is-incompatible/37448/3 "2020-12-01T14:49:04Z")

</div>

Is there any update on when Rasa x==0.34.x will be released?
