Unable to use rasa command

If tried to init or get help using rasa i am getting an error. Plz help soon

Welcome to the Forum. Jony :slight_smile:

Did you see any error while installing Rasa (in red)? You can try it again:

pip uninstall rasa rasa-sdk rasa-x
pip install rasa

@Jony-Jas Hello! Did you installed the rasa and rasa-sdk if not please install with this commands

pip install rasa==2.8.1 or latest

pip instal rasa-sdk==2.8.1

Please check that you had install the rasa in environment or not using

rasa --version and share with us run rasa init and follow the intersections

If you want to stop the the bot /stop

If you want to talk to again with bot you can use rasa shell --debug

I have not installed rasa-x . I ran the uninstall and reinstalled but still getting the same error.

@Jony-Jas you also want to install rasa-x? if yes please follow above commands and share with us rasa --version I will share you how you can install rasa x

I dont want rasa-x for now. if I use rasa --version command I am getting an error

@Jony-Jas I think you not seen my above post? please see my above post Unable to use rasa command - #3 by nik202

I have tried it and I am getting the same error.

@Jony-Jas please share rasa --version

I have installed rasa using pip install rasa==2.8.1 so I think the version is 2.8.1

please share us whilst using the command dnt think please :slight_smile: rasa --version in conda env

@Jony-Jas if you not getting any output then it’s not install my friend, that why I am asking.

I am getting error if I ran the command rasa --version

@Jony-Jas right, you need to create fresh condo environment, do you have Anaconda install in your system? Yes or No?

I tried with another laptop but also getting an error

@Jony-Jas J I personally tried to install on my window machine and I was able to create conda environment and then able to install rasa==2.8.1 (interesting fact is this now when we install rasa, rasa-sdk install automatically with 2.8.2), further I run the command rasa init and then able to chat.

This is quite strange behaviour. Please clear the temp files %temp% and try clear all cookies and caches too.


can you please disable telemetry rasa telemetry disable

and then try rasa init

or rasa --version and share me the error please

I am getting the same kinda error

@Jony-Jas I replicate the same process for 2.8.1 and on both my machine Mac and windows and I did not encountered this error. It really a issue.

@Jony-Jas Please can you mention the steps which you are doing till now, starting from the basic whilst creating anaconda and till this error generation.

@Jony-Jas I can see this really a bug as other users are also reporting the same errors now.

The steps I followed are :

conda create --name rasa3 python==3.8

conda activate rasa3

pip install rasa==2.8.1

After this, when I try to use rasa command it is not working. for every rasa command I am getting the same error.