# Unable to set Domain name

**URL:** <https://forum.rasa.com/t/unable-to-set-domain-name/46811>\
**Category:** \[Deprecated\] Rasa X Community Edition\
**Created:** [August 12, 2021, 2:24pm UTC](https://forum.rasa.com/t/unable-to-set-domain-name/46811 "2021-08-12T14:24:27Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![degrees](https://avatars.discourse-cdn.com/v4/letter/d/cdc98d/32.png) [@degrees](https://forum.rasa.com/u/degrees)\
**Post date:** [August 12, 2021, 2:24pm UTC](https://forum.rasa.com/t/unable-to-set-domain-name/46811/1 "2021-08-12T14:24:27Z")

</div>

Hello, recently I was tasked by my boss to set up a Rasa-X-Instanz on a VM (Ubuntu 20). Thanks to the [Guide]([https://The](https://The) Complete Guide to Deploying Your Rasa Assistant) by Karen White I was able to do so. My IT skills are rather limited, and so I am currently stuck trying to set a domain name.

The DNS entry was done by a colleague. I am currently using the following values file to update helm: `app: name: rasa/rasa-x-demo tag: 0.40.0 duckling: enabled: false eventService: tag: 0.40.1 global: debugMode: false postgresql: postgresqlPassword: KYv0ya8QGQkE2KqW\_o0\_ redis: password: 0Taxqwxo15k4eE5jVmtQ ingress: hosts:

- host: paths:
  - / tls:

- secretname: “” hosts:
  - 

nginx: http: server: listen: 443 listen: 80 server\_name: service: type: ClusterIP port: 8000 rabbitmq: rabbitmq: password: 3IiTqq689zc6UA2Re609 rasa: tag: 2.6.2-full rasax: port: 8000 disableTelemetry: false extraEnvs:

- name: QUICK\_INSTALL value: “true” initialUser: password: fWRMC11wjF4KQAn6nJxo tag: 0.40.1`

I know this is working, of a sorts, because if I set some value for the ports of rasax or nginx which isnt permitted by the firewall access to the UI of Rasa-x, i cant access it. But I am unable to set up the specific domain name for which the DNS entry exists. If I apply the above file with `helm upgrade --values rasa_project/values.yml --namespace rasa --reuse-values rasa rasa-x/rasa-x` the only effect I can observe is that I cant connect to the IP of the VM (Error 404) and if I try the domain the error says “Side not found”.

Does anybody has an idea to why that is, and how to solve it? I am currently at my wits end. Thank you in advance I also found this thread: [How to add an SSL using Let'sEncrypt for Rasa X on Kubernetes](http://forum.rasa.com/t/how-to-add-an-ssl-using-letsencrypt-for-rasa-x-on-kubernetes/37891)

---

<div class="post-metadata">

**Author:** ![degrees](https://avatars.discourse-cdn.com/v4/letter/d/cdc98d/32.png) [@degrees](https://forum.rasa.com/u/degrees)\
**Post date:** [September 8, 2021, 2:17pm UTC](https://forum.rasa.com/t/unable-to-set-domain-name/46811/2 "2021-09-08T14:17:55Z")

</div>

Okay, so heres the solution to all my problems:

- We “downgraded” to the docker-compose setup
- The DNS-Entry wasnt set up properly, after that and the correction of the paths for the certificates, everything works fine.

But a remark on the install-script for docker: in the docker-compose.yml the volume for the certs are being created via ` ./certs:/etc/certs` so ine the container its /etc/certs, but in the ssl.conf.template they are refered to by

```auto
 ssl_certificate /etc/nginx/certs/fullchain.pem;
 ssl_certificate_key /etc/nginx/certs/privkey.pem;

```

Which, the caused the nginx-server to never set up, because it could find the files which I provided to /etc/certs. Found the error after checking the logs and the paths.

tl;dr: issue solved with docker and a correct dns-entry

---

<div class="post-metadata">

**Author:** ![ChrisRahme](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.rasa.com/chrisrahme/32/15572_2.png) [@ChrisRahme](https://forum.rasa.com/u/ChrisRahme)\
**Post date:** [September 8, 2021, 3:15pm UTC](https://forum.rasa.com/t/unable-to-set-domain-name/46811/3 "2021-09-08T15:15:06Z")

</div>

Thank you for coming back and providing a solution 🙂
