Unable to run the Training Model - Getting a ModuleNotFoundError: No module named 'trainers' (although 'trainers' is present in Python/SitePackages)

Rasa version:0.7.2 Python version: 3.6.8 Operating system: Windows 10

Issue: Getting a ModuleNotFoundError: for trainers but in my Python/ Site Packages that ’ trainers’ folder is already present

Trying to train the ML model run. (following the github/rasa-site-bot)

python -m rasa_nlu.train -c AI-engine/config_spacy.json --data AI-engine/data/sitebot-data.json
from trainers.spacy_sklearn_trainer import SpacySklearnTrainer
ModuleNotFoundError: No module named 'trainers'

trainers is present in Site packages.

C:\Python3.6\Lib\site-packages\rasa_nlu\trainers

From Python terminal tried to import but got same result:

>>> from trainers.spacy_sklearn_trainer import SpacySklearnTrainer
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
ModuleNotFoundError: No module named 'trainers'

How can I mitigate the issue. Many thanks, Yend

Hi there Yend,

Can I ask why you are using such an old version of Rasa NLU? The tutorial you are following is relatively old and doesn’t have a version specified in its requirements. I would recommend starting with our Starter Pack and the latest releases of rasa instead.