empty in default action_session_start in Rasa 2.0

When trying to extract metadata from a custom connector request I came across this post: Set slots using request metadata

The code was very helpful and I was able to access the metadata through the default action action_session_start through the tracker.event field.

However when trying to run this code using Rasa 2.0, the tracker.event field will always return [] (an empty array).

My question: Why is tracker.event empty when the code is run in rasa 2.0, and if this is by design how would I access the metadata in the default action action_session_start?

hi! I think it might have been due to this issue Fix tracker init copy method by nbeuchat · Pull Request #7341 · RasaHQ/rasa · GitHub - can you please update and check?

Hi Alan, I am using rasa-sdk 2.1.2 and rasa version 2.1.1, but i still have the issue.

hi @nmvl - I just tried this again and wasn’t able to reproduce your error - the code you linked worked as expected.

I did run into one tricky thing though, which is that just adding the custom action (overriding the default) to my domain didn’t trigger rasa to re-train, so best to run with rasa train --force just to be sure when you introduct a new action.

Rasa Version     : 2.2.1
Rasa SDK Version : 2.2.0