SOLVED - My first trial - intent with entity correctly caught but no return of the value at the next "utter"


I am pretty new to RASA and steadily learning. To start with, I set up a completely new rasa environment rasa initi --no-prompt.

From this I amended the structure and simplified it to better learn RASA’s behavior. And here I am stuck. While the bot interprets the intent correctly and does ask for my name… I want to return the provided user name in the next question of the bot and here the bot simply does nothing with it and returns to “your input.”

I am providing my three key files, maybe someone can help me. Ideas is

“hi” “What’s your name?” “My name is Mario” “Hi, Mario. How can I help you?”

should be simple, but isn´t apparently. (926 Bytes) (201 Bytes) domain.yml (972 Bytes)


all the rest is taken from RASA INIT

Hope this helps and someone can help me! :slight_smile: at the end of the learning curve I would like to built a faq bot based on a mediawiki database. or something similar

Thanks Mario

it’s hard to say what’s going on. Did you try to turn on debug mode? See for details: Command Line Interface


I actually solved the problem differently.

I first renamed my intensions a bit to make it clearer and added {“firstname”:“Tom”} to the user intent, that made all work.

*greet -utter_ask_firstname *tell_firstname{“firstname”:“Tom”} -utter_greet_firstname

ps sorry for the formatting, but the preview screen shows it better than the actual outcome but I hope you understand what I try to pass as message