[Solved] Error when starting after upgrade

Hello,

I upgraded rasa x to the latest version (at the time rasa 1.3.7 and rasa-x 0.21.3), I do not know which version from (~ rasa 1.2 I believe). Since upgrading I get the error message “TypeError: cannot unpack non-iterable NoneType object” (Full Trace: rasa-error.txt · GitHub).

Based on the trace I assume it is an issue with the MD parsing, but the message provides no further info.

Is this a known issue? Is there any way to get more details on which MD file is affected and which line?

EDIT: debug log mode (-vv) lead me to the file, and a temporary modification of the markdown parser allowed me to log the line. The issue were two slashes ("/") in the intent name, replaced with underscores it loads again.

Thank you and best regards, Tao

1 Like

Great detective work @taotsetung! :guitar:

1 Like