SklearnIntentClassifier with custom "num_jobs" kwargs value

I was using the older version of Rasa before NLU and Core were joined and just upgraded to the latest version of X. I’ve got everything working except for one thing. Previously, when calling the equivalent of what is now “rasa train nlu blah” I was passing in a parameter “–num_jobs 8” and this was being picked up by Sklearn. Now with the new version, it says that “num_jobs” is an unrecognized parameter, understandably.

How can I pass “num_jobs” which is a kwargs value in Sklearn to it? I’m also using a custom pipeline if that makes any difference.

Hi Erik, I guess you want to pass the num_threads arg to the classifier? rasa/ at master · RasaHQ/rasa · GitHub

Yes, exactly. How can I do so?

hmm looking at the code it doesn’t look like we’ve made that configurable via the new CLI. I can’t see any reason why not though. Could you please create an issue? I think it would make a great contribution for someone. (If you are up for tackling it, that would be awesome! )

Thanks, I put in an issue here. I’ll take a look and see how long the change would take to make. If it’s a simple fix I can probably get to it CLI No longer accepts "num_threads" as a parameter for the sklearn intent classifier · Issue #4141 · RasaHQ/rasa · GitHub