Set up and instalation

Hey, I know there’s already a forum about this, but I couldn’t find it at the moment. I’m struggling with instaling: pip install -r requirements.txt it gives me this error and I can’t figure out what’s the issue here

Hey @rugkve (labas :slight_smile: )

You have to install Microsoft Visual C++ Build Tools as there are a few dependencies that need it to run on Windows. You should be able to do that by following the link provided in an error message.

Also, seems like you are using python 3.7, right? I would suggest creating a virtual env with python 3.6 and running Rasa there because some of the dependencies still need to be upgraded to run with 3.7.

1 Like

Hey,

Sorry for such a late reply, but I installed python 3.6 and it worked! Ačiū labai! :slight_smile:

But now I have another question, when I write: curl -X POST localhost:5000/parse -d ‘{“query”:“Hello”, “project”: “current”}’

This is what I get: image image image image

And also one question in advance. Is it possible to teach this AI lithuanian, I mean will it understand the symbols? :thinking:

Hey @rugkve. Is it likely you have something else running on the same port? Also, do you have your Rasa NLU model running on that specific port? You should be able to run the NLU model on the server with the following command:

python -m rasa_nlu.server --path ./models

Directory models should have a trained NLU model there.

Seaking of Lithuanian language, yes you should be able to build it in Lithuanian using a tensorflow embedding pipeline. The only thing you might need to do is to exclude the Lithuanian characters from the intent and entity names, but the messages themselves should be processed without any issues. Here is a result of one of my experiments back in a day:

Well I do this: image and then I open a new command prompt window and put this command curl -X POST localhost:5000/parse -d ‘{“query”:“Hello”, “project”: “current”}’. I checked and it seems that the port isin’t being used anywhere else :confused:

If it’s of any help, this is what it shows on the first window when I try to execute curl -X POST localhost:5000/parse -d '{"query":"Hello", "project": "current"}'

I fixed it. I put:

curl localhost:5000/parse?q=Hello^&project=current

instead of

curl -X POST localhost:5000/parse -d '{“query”:“Hello”, “project”: “current”}'

and it works. It’s probably due to the different syntax on windows. Well, hope that it will help if anyone has a similar problem.