Rasax: access rasa x with http://<vm-ip-address> instead of http://<vm-ip-address>:8000

Hello community !!

I used rasa x helm chart deployment on linux VM. I can access to the Rasa X server in my browser via http://:8000. I would like to be able to access to the Rasa X server via http://, meaning without having to specify the port. The main reason I want to do that is to be able to map my custom DNS to the Rasa x Url and allow SSL access by using certbot I have tryed nginx reverse proxy, as well as Apach one, but it didn’t work. Maybe I didn’t do it well.

Thank you !!

You don’t need to specify the port on a Helm Chart or Quick Install deployment (don’t know about Docker Compose) to access Rasa X. It’s weird that you do.

Do you have any other application on port 80 such as Apache2?

Hi ChrisRahme,

No, I have no other application on port 80. Actually, I start on a empty VM and followed the Rasa Advanced Deployment Workshop . And exactly like in the workshop I used port 8000 to connect. But based on what you said, I will try to just allow port 80 connection in Azure networking and try without specifying the port 8000.

I will keep you posted.

Thank s

1 Like

If it’s giving you trouble, you can go for the Quick Installation instead.

No need to worry about flexibility and lack of customization, since after installing, it is exactly like a Helm Chart Installation, and you will be to modify the values.yml files with helm upgrade as usual :slight_smile:

Thank you very much, I will try that as well ^^. Hope this will slove my problem

1 Like

Right after de deployment is over with helm chart i get this:

and when I go to http://ip-address I get this:


and finally when I go to http:// ip-address:8000 I get this:

Look like I don’t have the choice. I will try quick install now to se I will get more luck ^^’

1 Like

My end goal is to connect to Rasa x with https ^^ so if there is an easy way to doing that, my ears are wide open ^^’

Thanks !!! It worked with quick install !!

but it gave me this message :****** But instead of being able to access my rasa-x via the private ip address (, I was able to access it via the public ip address as I wanted ^^…

Now all I need is to custom my values.yml file

Glad to know you got it working :slight_smile:

I don’t know how to use HTTPS instead of HTTP (obviously you need a certificate), but I think it’s more related to Helm then Rasa. Maybe this can somewhat help?

I think the same applies for private vs public IP as well, maybe you can find more info here.

As you said, now you just have to modify your values.yml. Good luck :slight_smile:

Hello again ^^'.

I am stuck on an issue that I don’t know how to resolve. I am trying to configure SSL on my rasax web server. I am following this tutorial:

I succed in creating a DNS and mapping it to my vm ip address so I can connect to my rasa x just like this:

As the above tutorial suggested.

But instead of getting this


I get this:

Any idea of how to solve it ?


No idea, sorry.

I would suggest creating a new thread since it’s unrelated to this one - it will also let people be aware that you need help if they see a new thread with no replies.

All rigth, thanks ChrisRahme !

1 Like

hello, sorry to bring it back i have deployed my assistant but i cant reach it i have tied http://my-ip:8000 but nothing the only time it work is when i run this command to forward the port

kubectl --namespace mynamespace port-forward svc/myserive 5002:5002