Rasa x task was destroyed

I get this error when starting rasa x every time. It seems to then wait 5 minutes and start up OK. I have tried with empty endpoints.yml and still get the error. There is an issue on github but it is closed without an answer.

2021-11-22 17:41:43 ERROR asyncio - Task was destroyed but it is pending! task: <Task pending name=‘Task-8’ coro=<TCPConnector._resolve_host() running at /home/simon/.local/lib/python3.8/site-packages/aiohttp/connector.py:865> wait_for=<Future finished exception=gaierror(-2, ‘Name or service not known’)> cb=[TCPConnector._create_direct_connection..drop_exception() at /home/simon/.local/lib/python3.8/site-packages/aiohttp/connector.py:1002]> 2021-11-22 17:41:43 ERROR asyncio - Unhandled exception in event loop Traceback (most recent call last): File “uvloop/dns.pyx”, line 389, in uvloop.loop.__on_addrinfo_resolved File “uvloop/loop.pyx”, line 894, in uvloop.loop.Loop._getaddrinfo.callback File “uvloop/loop.pyx”, line 1257, in uvloop.loop.Loop.call_soon File “uvloop/loop.pyx”, line 635, in uvloop.loop.Loop._call_soon File “uvloop/loop.pyx”, line 639, in uvloop.loop.Loop._call_soon_handle File “uvloop/loop.pyx”, line 668, in uvloop.loop.Loop._check_closed RuntimeError: Event loop is closed

@simonm3 Are you installing local machine or server? can you share the rasa --version please?

Rasa Version : 2.8.12 Minimum Compatible Version: 2.8.9 Rasa SDK Version : 2.8.2 Rasa X Version : 0.42.4 Python Version : 3.8.5 Operating System : Linux- Python Path : /usr/bin/python3

ubuntu on wsl2/windows10. clearing cookies and cache does not fix

@simonm3 Its a local machine or server? you missed my question above?

Note: Always mention me with @ and nik202 for faster reply. Thanks.

after the message it seems to do nothing but then starts working in 2-3 minutes.

@simonm3 Please its your local machine right yes or no? Then I can give you better solution Simon!

@nik202 it is local machine

@simonm3 Finally!!! :slight_smile:

For Installation please follow these steps:

Please follow these steps for the installation of ROS and Rasa X :slight_smile:

Please install Anaconda from Anaconda | Individual Edition , then create the conda environment using the following command

  1. conda create -n rasa3 python=3.8
  2. conda activate rasa 3

PS: If you using Linux, check the environment for the same.

Note: I’d recommend to create a fresh environment if not you can proceed with next steps:

For Rasa Open Source:

`pip install rasa==2.8.1`
`pip install rasa-sdk==2.8.1'

check version rasa --version its install or not

For Installing basic project:

rasa init

then if you need

For Rasa-X Installation

pip install rasa-x==0.39.3 --extra-index-url https://pypi.rasa.com/simple

check rasa version rasa --version its install or not

You will see some error : ImportError: cannot import name ‘RowProxy’ from ‘sqlalchemy.engine’ Install

pip install SQLAlchemy==1.3.22 should fix it

If sanic related error: pip install sanic-jwt==1.6.0

delete .db (events and rasa ) if is showing alembic issue.

Note: If you not able to install and taking a lot of time you can downgrade the pip version to 20.2

pip install pip==20.2

If you have any error in-between please share with me.

Note: You will see the Event Loop Close error in the terminal, you can ignore that, its an persistent issue with Rasa X and team is working on it.

I hope this will solve your issue. Good Luck!

PS: First try install basic mood bot of rasa, talk and then go to other project.

So it says in the note above that “You will see the Event Loop Close error in the terminal, you can ignore that, its an persistent issue with Rasa X and team is working on it.”

That is the error I have so I guess it was fine all along. :grinning:

@simonm3 Yes, Is you Rasa X is up and running? If yes please close this thread as solution for yourself and for others. Good Luck!

Problem resolved thanks…there is no close button though :grinning:

@simonm3 it should be next to every conversation, just tick the solution .

thanks. on a mobile it just shows as a tick icon.

@simonm3 No worries, glad it solved your issue.Good Luck for your project!