Rasa X is incompatible to Rasa 3.0

When I upgrade Rasa from version 2.0 to version 3.0, here is a install error: rasa-x 0.42.5 requires rasa<3.0.0,>=2.8.11, but you have rasa 3.0.0 which is incompatible.

Which version of Rasa x do I need to install? Thanks.

Welcome to the forum :slight_smile:

Please see the Compatibility Matrix. Looks like Rasa X does not support Rasa 3.0 yet.

Hello and Welcome to the Community Forum @Givan !

can you please share the rasa --version for us ?

As, the error, suggest rasa required 2.8.11, even what command you are using to upgrade rasa 2->3, is you Rasa X running on local machine or server?

@nik202 The version of my rasa is 2.8.14 for now. I want to upgrade Rasa to Version 3.0 using the command

pip3 install rasa 

The command is to install Rasa of latest version (default 3.0). And my Rasa X is running on local machine

Thanks for your kind and useful response

1 Like

This is a very informative blog for me. I am very much benefited after reading this blog. Keep sharing.

Hi @ChrisRahme, Any idea when will Rasa-X be released for Rasa 3.0?

No sorry, I don’t work at Rasa, just a volunteer moderator :slight_smile:

Yeah, would be a nice “detail” to know that Rasa 3.X is not yet compatible with RasaX (and how long)… :wink: