Rasa Webchat Integration

I think I know what the problem is. I’m serving the Webchat app with Apache. It is probably not allowing access to Rasa server. I’m trying to find out how to configure it.

Any alternative server suggestions are welcome! Also if you find anything wrong with the Rasa server logs, please reply…

I guess Apache is not the problem: I tested the app with my laptop’s Apache and it worked. There should not be any special configurations there.

Hello @Kejender,

The only line with fail on load is the one below, so I’ll plot the answer on it.

It says that is the model for the component ResponseSelector so I dug a little and found this link on documentation.

Link: faqs-response-selector

Reading the documentation I started to wonder that you configured your config.yml to use the ResponseSelector component but didn’t feed the responses.md file.

Can you check the items above and if it’s not any of them reply with all your configs files?


Hi, thanks. I removed the ResponseSelector and that error is not coming any longer. This is the initial “moodbot”, created with rasa init. The problem still persists. I still suspect it is related to Apache. I have been checking the .conf files in both servers but they seem similar.


1o. You’re welcome!

2o. Don’t you have a registry of the attempts anywhere? (rasa, apache, OS logs, firewall, proxy and etc.)

Any additional information can help us to help you… :grin:

I may have a solution coming up, let’s see tomorrow…


Great!!! :grin:

Please share with us if it works!

Hi! Now it is working. I’m afraid I had some misconceptions about networking. I’m still not sure if I fixed it right, feel free to comment…my bot is in my internal network so it should be safe.

First I had to open the port 5005 in my server. Then in WebChat’s configuration, replaced “localhost” with server’s public ip.

Hello @Kejender,

glad it worked out!

Please mark your reply as solution.


Hey buddy…thanks for such an informative tutorial…could you please help me in putting the persistent menu in the header for the webchat widget that is there in botfront or other tutorials…i’ve added the webchat code in my dummy website and there it is a REACT code, so how to bring the persistent menu in header with the options of Clear, Restart, and Close. help wud be much appreciated. thnx

@JiteshGaikwad i followed this instructions but i got blank values

@lkrishnaprasad can you show error logs or screenshot?

This problem is resolved. Thanks. i had missed some steps you had given. Now its okay.

Hey @Aashay1. I’m stuck in the same situation. I need to send the userid from my website session data to chatbot and set in my custom action and pass on to the api. How do i do that?

Were you able to retrieve data from your website to bot using customData and print it?

@JiteshGaikwad I need help in sending the data in my website session i.e., userId to my api via custom actions using customData.

// Or you can replace latest with a specific version WebChat.default.init({ selector: "#webchat", initPayload : '/get_started{"userID":"163","user_name":"Aashay"}' , customData:{"userID":"163","user_name":"Aashay"}, // arbitrary custom data. Stay minimal as this will be added to the socket socketUrl: "http://localhost:5005", socketPath: "/socket.io/", title: "Beehive Bot", subtitle: "I'am still under development", params :{ storage : "session" } })

Hey do you have a email or something? This work needs more contact than just comments.

Why you defined UserID twice? Once in payload and once in customData? And also like is there a way where i can pass session data in my website to customdata