Rasa Deploy Issue - Remote Storage

So for some reason when I try to setup my container instance in AWS ECS I get the below error:

The command values supplied to my container

"command": [
        "run --remote-storage aws -vv"

This however gives me in cloudwatch - rasa: error: invalid choice: 'run --remote-storage aws -vv' (choose from 'init', 'run', 'shell', 'train', 'interactive', 'test', 'visualize', 'data', 'x')

But if I run this locally works fine and gives me the AWS error about the bucket I would expect:

docker run -p 5005:5005 rasa/rasa:latest-full run --remote-storage aws -vv

So I’m sure I’m missing something stupid but does anyone else see it? Not sure why it wouldn’t work in AWS but does locally ok.

Is this the first time you’ve used ECS to run a container start command? The ECS syntax is kind of abysmal and took me some debugging to get it right. Not quite sure what it looks like from the yaml config, but can you post a screenshot of what the command looks like if you check it out in the console?

I think the issue is that it’s somehow passing run --remote-storage aws -vv as one parameter.

No I do this on a daily basis and this is the first app to give me any issue honestly. I’ve tried it as multiple params and one single, I’ll keep messing with it.

So looks like it wants it like this from a ECS perspective guess each argument needs to be on a line


Thanks for coming back with the solution!

Not a problem now just gotta get my bucket stuff setup and pulling the model from it :slight_smile: