Rasa core 13.0

installation
(Ramesh Jantali3) #1

i am using tensorflow = 1.11.0 and rasa_core =0.13.0 getting below error fp, pathname, description = imp.find_module(’_pywrap_tensorflow_internal’, [dirname(file)]) File “C:\Anaconda3\lib\imp.py”, line 297, in find_module raise ImportError(_ERR_MSG.format(name), name=name) ImportError: No module named ‘_pywrap_tensorflow_internal’

During handling of the above exception, another exception occurred:

Traceback (most recent call last): File “C:\Anaconda3\lib\site-packages\tensorflow\python\pywrap_tensorflow.py”, line 58, in from tensorflow.python.pywrap_tensorflow_internal import * File “C:\Anaconda3\lib\site-packages\tensorflow\python\pywrap_tensorflow_internal.py”, line 28, in _pywrap_tensorflow_internal = swig_import_helper() File “C:\Anaconda3\lib\site-packages\tensorflow\python\pywrap_tensorflow_internal.py”, line 20, in swig_import_helper import _pywrap_tensorflow_internal ModuleNotFoundError: No module named ‘_pywrap_tensorflow_internal’

Failed to load the native TensorFlow runtime.

See https://www.tensorflow.org/install/install_sources#common_installation_problems

for some common reasons and solutions. Include the entire stack trace above this error message when asking for help.

0 Likes

(Ella Rohm-Ensing) #2

Hi there @rameshJantali3, welcome to the forum! Did you download the requirements in requirements.txt? Rasa core 0.13.0 runs on tensorflow 0.12.0, not 1.11.0. If there’s some specific reason you need to have 1.11.0 installed, I’d recommend creating a virtual environment for your Rasa project where you can install all of the requirements with no worries about changing your versions for other projects.

0 Likes