Missing parameter in a part of the documentation?


(Githubkoma) #1

Dear Team,

thanks so far for the great project! Keep it up :slight_smile:

Took me some time to figure out that in the documentation perhaps a parameter is not mentioned? I’m not quite sure…: https://rasa.com/docs/core/connectors/ -> Mattermost

it says: python -m rasa_core.run -d models/dialogue -u models/nlu/current \ --port 5002 --credentials credentials.yml But when i run it with -vv its not listing my mattermost webhook:

2018-09-09 18:18:38 DEBUG    rasa_core.utils  - Available web server routes:
static                                             HEAD, GET, OPTIONS             /static/[filename]
custom_webhook.health                              HEAD, GET, OPTIONS             /webhooks/rest/
custom_webhook.receive                             OPTIONS, POST                  /webhooks/rest/webhook
2018-09-09 18:18:38 INFO     root  - Rasa Core server is up and running on http://localhost:5002

instead i have to use:

python -m rasa_core.run -d models/dialogue -u models/nlu/current \
    --port 5002 --credentials credentials.yml --connector mattermost

now its listed and working just fine:

2018-09-09 18:20:25 DEBUG    rasa_core.utils  - Available web server routes:
static                                             GET, OPTIONS, HEAD             /static/[filename]
mattermost_webhook.health                          GET, OPTIONS, HEAD             /webhooks/mattermost/
mattermost_webhook.webhook                         OPTIONS, POST                  /webhooks/mattermost/webhook
2018-09-09 18:20:25 INFO     root  - Rasa Core server is up and running on http://localhost:5002

I found that that hint in an older documentation https://rasa.com/docs/core/0.9.8/connectors/

so i am not sure if this is a small mistake in the docs, or if i did something wrong.

But thanks to that parameter, it works now, just wanted to share…

best regards


(Akela Drissner) #2

@tmbo any reason the --connector flag is no longer a part of those docs?


(Akela Drissner) #3

Just an update, you don’t need the --connector flag anymore (but can still use it if you want), it will automatically start webhooks for all the channels you provide in your credentials file. This was fixed in a PR that we merged today