Issues with redis after MacBook update

Hey everyone, has anyone got this Redis Error before? How did you resolve it?

I just updated both of my macbooks to 12.0.1 (Monterey) and on both of my laptops I can’t run rasa anymore. I am getting this error when running rasa actions. Does anyone have ideas on how to resolve this?

I tried reinstalling redis / making sure it runs using “redis-server”, but this didn’t help. Is there a way to disable redis for Rasa at all maybe? I actually don’t have redis in my endpoints so I wonder why am I getting any redis related errors at all.

I’m using python 3.7 and rasa==2.6.2, rasa-sdk==2.6.0, redis==3.5.3.

Traceback (most recent call last):
  File "/opt/miniconda3/envs/hobbes37/lib/python3.7/site-packages/redis/", line 559, in connect
    sock = self._connect()
  File "/opt/miniconda3/envs/hobbes37/lib/python3.7/site-packages/redis/", line 585, in _connect
  File "/opt/miniconda3/envs/hobbes37/lib/python3.7/", line 752, in getaddrinfo
    for res in _socket.getaddrinfo(host, port, family, type, proto, flags):
socket.gaierror: [Errno 8] nodename nor servname provided, or not known

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/opt/miniconda3/envs/hobbes37/lib/python3.7/site-packages/sanic/", line 938, in handle_request
    response = await response
  File "/opt/miniconda3/envs/hobbes37/lib/python3.7/site-packages/rasa_sdk/", line 104, in webhook
    result = await
  File "/opt/miniconda3/envs/hobbes37/lib/python3.7/site-packages/rasa_sdk/", line 398, in run
    action(dispatcher, tracker, domain)
  File "/Users/shakurova/personal/Dwell-Chat-Bot/actions/", line 34, in run
    units, filter_attributes = self.run_unit_search(tracker, None)
  File "/Users/shakurova/personal/Dwell-Chat-Bot/actions/", line 185, in run_unit_search
    data = load_data(property)
  File "/Users/shakurova/personal/Dwell-Chat-Bot/actions/", line 34, in load_data
    data = json.loads(cache.get(property))
  File "/opt/miniconda3/envs/hobbes37/lib/python3.7/site-packages/redis/", line 1606, in get
    return self.execute_command('GET', name)
  File "/opt/miniconda3/envs/hobbes37/lib/python3.7/site-packages/redis/", line 898, in execute_command
    conn = self.connection or pool.get_connection(command_name, **options)
  File "/opt/miniconda3/envs/hobbes37/lib/python3.7/site-packages/redis/", line 1192, in get_connection
  File "/opt/miniconda3/envs/hobbes37/lib/python3.7/site-packages/redis/", line 563, in connect
    raise ConnectionError(self._error_message(e))
redis.exceptions.ConnectionError: Error 8 connecting to redis:6379. nodename nor servname provided, or not known.

@llotus_eater Can you please update rasa and rasa-sdk to the latest versions or to rasa and rasa-sdk 2.8.1?

@nik202 I think the problem is in something else. I just found out that from command line it still works perfectly well, however, if I run actions from PyCharm, that’s when I get redis error. I wonder what could have caused it. Any ideas?

@llotus_eater I never worked on PyCharm personally, I hope you installed all the packages for Redis I guess interpreter something like that and even I never worked with miniconda3.