Issue with upgrading Rasa


I just ran pip install rasa --upgrade to upgrade rasa and the installation process did complete but during installation in red text got the messages:

rasa-x 0.20.3 has requirement jsonschema~=2.6.0, but you’ll have jsonschema 3.2.0 which is incompatible. rasa-x 0.20.3 has requirement rasa~=1.2.9, but you’ll have rasa 1.6.0 which is incompatible. rasa-x 0.20.3 has requirement sanic~=19.3.1, but you’ll have sanic 19.12.2 which is incompatible.

Just wondering what to do next. Thx.

You can directly ‘pip install rasa’ without ‘upgrade’ for any package. You want to install those packages which would be compatible with rasa. So install the packages according to the requirements. example : pip install jsonschema==2.6.0. You might encounter similar issue in the future if you install rasa-nlu or rasa-core.Keep this solution in mind. Also, various packages are incompatible with different versions of rasa,rasa-x,rasa-core, so be careful which version of packages you install.