Install rasa-x error

hi I encountered this error while installing rasa x

pip install rasa-x --extra-index-url Simple Index then

How to solve Thank you(,・ω・,)

@dan246 can I get to know what is your rasa version and python? @dan246 Or see this solution Problem with mulidict version when installing Rasa X in windows 10 local environment - #9 by alINGeNT

python: 3.8

@dan246 please see above post of my and link I shared at the end only solution. try.

Ran the same error in 9. pip install rasa-x==0.40.0 --extra-index-url Simple Index


  1. conda create --name NAME python==3.8 conda activate NAME
  2. conda install ujson
  3. conda install tensorflow
  4. check for pip version: pip --version (Should be latest version > 21.1.x) pip install rasa==x.x.x (refer version below)
  5. down grade pip version pip install pip==20.2 --user
  6. pip install rasa-x==x.x.x --extra-index-url (refer version below)

Versions: python --version Python 3.8.0

rasa --version Rasa Version : 2.6.2

Minimum Compatible Version: 2.6.0

Rasa SDK Version : 2.6.0

Rasa X Version : 0.40.0

Python Version : 3.8.0

Operating System : Windows-10

I created

pip version

@dan246 update setuptools pip install setuptools

I guess you ignore some dependencies, that why throwing the error.

I redo the steps and still have the same problem(´;ω;`)

@dan246 Can you share email id so that I can assist you. If you want. Thanks.


help I have the same error as above

my email

@hoangnguyen1222 you need to create the new python conda environment and then see the above mentions steps.

i am using anaconda3 to install i have reinstalled python and have done the steps but still error

@hoangnguyen1222 I said conda environment for your problem, not anaconda installations. I hope you got my point?

1 Like

i installed the apartment environment but still have the above problem

@hoangnguyen1222 apartment environment? What do you exactly mean by this?

this is exactly what i did

@hoangnguyen1222 activate your environment and install rasa==2.8.1 and rasa-sdk==2.8.1 and rasa-x==0.39.3 and then share rasa --version