Getting error while running rasa x locally

I was trying to install rasa x and run it from my local system. Till the “rasa init --no-prompt” command it works fine, but when I tried to run the "rasa x "command it is showing some errors and not working. I am adding the screenshots of the error here. Also adding the versions of the packages I am using below. Can someone please help me to sort out this error?

commands I used to install rasa x pip3 install rasa-x --extra-index-url Simple Index --use-deprecated=legacy-resolver rasa init --no-prompt rasa x

packages and os Rasa Version: 2.8.1 Minimum Compatible Version: 2.8.0 Rasa SDK Version: 2.8.1 Rasa X Version : 0.42.4 Python Version: 3.7.11 Operating System: Windows-10-10.0.19041-SP0

Hi @akhilsiby,

I’m facing the same issue. Probably it’s because rasa x fails to connect via HTTPS.

In debug mode you can see more details:

DEBUG:urllib3.connectionpool:Starting new HTTPS connection (1):

2021-11-11 09:21:54 DEBUG - Rasa X will use <class ‘’> for caching queries.

2021-11-11 09:21:54 DEBUG rasa.core.agent - Tried to fetch model from server, but couldn’t reach server. We’ll retry later… Error: Cannot connect to host localhost:5008 ssl:default [Connect call failed (‘’, 5008)].

The solution could be to certify localhost on your machine via OpenSSL

@Darkkap are you able to solve this ?

@akhilsiby Hi, Akhil. Honestly, this is a nightmare for me also, and I hope Rasa Team is working on this issue.

Meanwhile, if you want to install rasa x and want to explore this GUI you can install the lower version of rasa x.

@akhilsiby Even, if you are now not concerned about the rasa CDD and GitHub connectivity, I will recommend you the following steps, and please stick to that and you will be able to install rasa x with ease.

For Installation please follow these steps:

Please follow these steps for the installation of ROS and Rasa X :slight_smile:

Note: You can ignore a few steps if you already performed it!

:wink: But I’d recommend starting the fresh installation without seeing any video, please.

Please install Anaconda from Anaconda | Individual Edition , then create the conda environment using the following command

  1. conda create -n rasa3 python=3.8
  2. conda activate rasa 3

PS: If you using Linux, check the environment for the same.

Note: I’d recommend to create a fresh environment if not you can proceed with next steps:

For Rasa Open Source:

`pip install rasa==2.8.1`
`pip install rasa-sdk==2.8.1'

check version rasa --version its install or not

For Installing basic project:

rasa init

then if you need

For Rasa-X Installation

pip install rasa-x==0.39.3 --extra-index-url

check rasa version rasa --version its install or not

You will see some error : ImportError: cannot import name ‘RowProxy’ from ‘sqlalchemy.engine’ Install

pip install SQLAlchemy==1.3.22 should fix it

If sanic related error: pip install sanic-jwt==1.6.0

delete .db (events and rasa ) if is showing alembic issue.

Note: If you not able to install you can downgrade the pip version to 20.2

If you have any error in-between please share with me.

Note: You will see the Event Loop Close error in the terminal, you can ignore that, its an persistent issue with Rasa X and team is working on it.

I hope this will solve your issue. Good Luck!

PS: First try install basic mood bot of rasa, talk and then go to other project.

I’m sure you will able to install and run rasa x with ease :wink: If not tag me :slight_smile:

1 Like

hello, you can find here a video that explain how to add ssl configuration via certbot hope it helps :

Preformatted text(Ep #11 - Rasa Masterclass) Connecting an assistant to external messaging channels | Rasa 1.8.0

Hello @M_R_LY What is your current Rasa X Version?

hi , its the last one 0.42.2 the philosophy is the same so you can try it

@M_R_LY can you share the steps, for the installation, It will help others while installing the Rasa X latest version. when ever you got some time?

@M_R_LY This one is related to When we trying to Install Rasa X on server side, then the Http link is not secure, for that we need this process.

@M_R_LY Back to square one, please confirm your Rasa X is installed on local machine ( local mode) or on the Server Side whilst using Quick Installation or Docker?


hello, i just followed the installation guide in the documentation I had in in local first and then moved to serve side

but its the same just follow the documentation and everything should be fine

and i used docker

@M_R_LY means you are not using the local mode (local machine) of Rasa X ?

both on my local machine i ame using local rasa x

for the server i am not husing local machine but docker

for the local one i am not using ssl . if you use ngrock you will automatically have ssl

Can you share the rasa --version for the same?

Right! No worries

I guess you are using Rasa X latest image tag for the same

ok lets do this what is exactly your problem and its about local or server side ?

@M_R_LY Bro. I don’t have any issue with installation both on the local machine and on the server side. As you mentioned here is the suggested solution: Getting error while running rasa x locally - #5 by M_R_LY that’s why confirming with you. The solution you suggested is useful when you are installing the rasa x on server side. I hope you got my point now and discussion for the same :slight_smile:

Hi! I had a similar problem with the latest version of rasa x also. You can try downgrading the rasa x to 0.39.3. You can refer to this - Error running rasa x - <Future at 0x2b5686c4400 state=finished raised gaierror> on Windows - #6 by nik202

Thanks to @nik202 :slight_smile:

@lis :stuck_out_tongue: :star_struck: Thanks for sharing the solution.

1 Like

oh okey my bad so

he can use it i think it should work for https link he should use ngork or build a self signed certificat with certbot you in any case a public ip is necessary

@M_R_LY you are not getting my point bro, if he is installing rasa x local mode (local machine), then he not required to secure the http and if he is installing on server then for sure.

1 Like

oh okey i see

yeah so definetly i think that the problem is not about ssl