Error running rasa x - <Future at 0x2b5686c4400 state=finished raised gaierror> on Windows

Hi, I’ve been getting this error when I run rasa x

ERROR concurrent.futures - exception calling callback for <Future at 0x2b5686c4400 state=finished raised gaierror>

This is what I get when I type rasa --version

    1. Rasa Version : 2.8.12
    1. Minimum Compatible Version: 2.8.9
    1. Rasa SDK Version : 2.8.2
    1. Rasa X Version : 0.42.4
    1. Python Version : 3.8.8
    1. Operating System : Windows-10-10.0.19041-SP0

According to the compatibility matrix, I see that the rasa x I have installed is compatible with rasa version.

I have tried out different suggestions from other forum members in other such similar posts, but nothing seems to be working. Can someone help me with this?

@lis Hello Lisa, I have seen your other post regarding Rasa X, if you are planning to use rasa X for CDD, then local mode installation will not work for your case.

Rasa X is intended to be deployed on a server and not to a personal/local machine. Deploying on a server is recommended because Rasa X is designed to stay up continuously, and not to be frequently stopped or restarted.

Integrated Version Control encourages best practices by integrating itself into your existing development workflows. It lets you automate data synchronization with your Git repository, annotate new data and push those changes with Git.

In order to connect Rasa X with your assistant’s Git repository, you will need two things:

  1. A Rasa X instance running in server mode (local mode does not support Integrated Version Control)
  2. A Git repository containing a project in the default Rasa Open Source project layout

If you want to explore the Rasa X in local mode and having issue in installation, please do let me know; I will provide the clean installation steps.

For current installation issue, can you share me the screenshots:

  1. Run rasa --version in your active environment

  2. Run rasa x and share the error screenshot please, a complete error

@lis I hope you seen the above section of post? can you confirm are you able to see the rasa x in default web browser?

@nik202 Yes, I’m trying to have a local installation to have a look at how rasa x UI works. And no, I’m not able to see rasa x in the default web browser. It exits with the above error message

@lis Right, if you are now not concern about the rasa CDD and GitHub connectivity, I will recommend you the following steps, and please stick on that and you will able to install rasa x with the ease.

For Installation please follow these steps:

Please follow these steps for the installation of ROS and Rasa X :slight_smile:

Note: You can ignore a few steps if you already performed it!

:wink: But I’d recommend starting the fresh installation without seeing any video, please.

Please install Anaconda from Anaconda | Individual Edition , then create the conda environment using the following command

  1. conda create -n rasa3 python=3.8
  2. conda activate rasa 3

PS: If you using Linux, check the environment for the same.

Note: I’d recommend to create a fresh environment if not you can proceed with next steps:

For Rasa Open Source:

`pip install rasa==2.8.1`
`pip install rasa-sdk==2.8.1'

check version rasa --version its install or not

For Installing basic project:

rasa init

then if you need

For Rasa-X Installation

pip install rasa-x==0.39.3 --extra-index-url https://pypi.rasa.com/simple

check rasa version rasa --version its install or not

You will see some error : ImportError: cannot import name ‘RowProxy’ from ‘sqlalchemy.engine’ Install

pip install SQLAlchemy==1.3.22 should fix it

If sanic related error: pip install sanic-jwt==1.6.0

delete .db (events and rasa ) if is showing alembic issue.

Note: If you not able to install you can downgrade the pip version to 20.2

If you have any error in-between please share with me.

Note: You will see the Event Loop Close error in the terminal, you can ignore that, its an persistent issue with Rasa X and team is working on it.

I hope this will solve your issue. Good Luck!

PS: First try install basic mood bot of rasa, talk and then go to other project.

I’m sure you will able to install and run rasa x with ease :wink: If not tag me :slight_smile:

1 Like

Thanks a lot @nik202, this works for me.

@lis Great! :+1: Congratulations

Valuable links and resources for your reference

  1. RasaMasterclass
  2. Conversational AI with Rasa - Video Series [Latest]
  3. Rasa for Beginners
  4. Rasa Certification Workshop
  5. Rasa Advanced Custom Actions, Forms, & Responses Workshop No-longer accepting enrolments
  6. Rasa Advanced Deployment Workshop
  7. Rasa Youtube Channel Please subscribe and hit the bell icon for notification.
  8. Rasa Github Mini Project
  9. Rasa Masterclass Handbook
  10. Hardcopy Book : Conversational AI with Rasa

I hope these links will help you to learn Rasa!

1 Like