Enable SSL for Rasa core server


(Krishna) #1

My site hosted in wamp server with the proper SSL certificate is installed. From my site i am calling the rasa core HTTP API. I am getting the below error

Mixed Content: The page at ‘https://mysite.com/index.php#’ was loaded over HTTPS, but requested an insecure XMLHttpRequest endpoint ‘http://:5005/conversations/default/respond’. This request has been blocked; the content must be served over HTTPS.

How to install the SSL certificate for RASA Core server? Using postman i am getting the response correctly. Thanks in Advance


(Souvik Ghosh) #2

Where are you running the chatbot? what infrastructure


(Krishna) #3

The main site is hosted in wamp server (installed in windows server 2008) and I have installed RASA Core server in the same machine.


(Souvik Ghosh) #4

does this work?

https://mysite.com/conversations/default/respond

??


(Souvik Ghosh) #5

usually SSL is enabled on your domain, not linked to a particular application. your CA will verify if the domain is associated to an IP address

in my case with my custom server, I enable SSL for the domain and provide my keys to the server ( It is a windows server with Plesk ) this enables SSL for all my applications running tomcat for example


(Krishna) #6

No it didn’t work. I have got this response from the team


(Souvik Ghosh) #7

Ow, we use kubernetes which has by default nginx proxy to route to pods exposing services.

Use nginx I suppose