Cannot stop Rasa X

So, I updated rasa-x to 0.26, I had problems with training so I wanted to come back to the old version. I couldn’t find a way, so I tried to create a new project: I renamed /etc/rasa and started over with the Install procedure, creating a new /etc/rasa.

Now I don’t know what is happening. My Rasa X UI is constantly on, I can’t control it, even if I run docker-compose down it’s still there, I don’t understand to what it is linked and how can I shut it down and start over…

I hope someone can help me out.

Thank you, Tiziano

What does docker ps give you?

This may sound like a stupid question, but did you try refreshing the localhost server page?

I don’t have a localhost page, I have the IP of my server, and yes I refreshed it, but I still get the Rasa X UI

That’s peculiar. :thinking:

I renamed /etc/rasa

What exactly do you mean by this?

that I renamed the directory and created a new one

Does anybody know how to help me?

The problem is: I have Rasa X running on my server IP address, even if I run docker-compose down it keeps there, I don’t understand what it is connected to and how to manage it

can you try going to the newly renamed directory and running docker-compose down there? It seems like it should show in sudo docker ps though. What if you run sudo docker ps -a or docker container ls -a?

Hi @erohmensing thank you for your reply.

I deleted that instance of virtual machine. I created a new one but I’m struggling since days trying to install Rasa X. Do you have some time for helping me out? FATAL: password authentication failed for user "admin"

Thank you

I have same problems with @tiziano. Can anyone help me? I really appreciate. Thanks a lot.

@tiziano I have fixed my issue. You can try:

  • Firstly, stop k3s service by command “sudo systemctl stop k3s”
  • Uninstall k3s by command “k3s-uninstall.sh”