AttributeError: 'Sanic' object has no attribute 'auth'

Hi, not working with this combination as well.

@NehaManglani Try this

pip install rasa==2.8.2
pip install rasa-sdk==2.8.2
pip install rasa-x==0.39.3 --extra-index-url https://pypi.rasa.com/simple

Thanks @nik202. Now getting: File β€œ/Users/nehamanglani/opt/anaconda3/lib/python3.8/site-packages/alembic/script/revision.py”, line 386, in _revision_for_ident raise ResolutionError( alembic.script.revision.ResolutionError: No such revision or branch β€˜652500998f3e’

@NehaManglani delete .db file of events and rasa and then run rasa x. Good luck!

@NehaManglani did this work?

there was another error and I ran below pip3 install SQLAlchemy==1.3.22

now the rasa x is command is stuck at: DEBUG:rasax.community.database.utils:Turned SQLite foreign key enforcement on.

DEBUG:rasax.community.database.utils:Turned on SQLite WAL mode.

DEBUG:urllib3.connectionpool:https://api.segment.io:443 β€œPOST /v1/track HTTP/1.1” 200 21

@nik202 and if I type something on rasa shell, I get below on rasa x.

File β€œ/Users/nehamanglani/opt/anaconda3/envs/rasaenv/lib/python3.8/site-packages/aiohttp/client_reqrep.py”, line 1000, in raise_for_status raise ClientResponseError( aiohttp.client_exceptions.ClientResponseError: 404, message=β€˜Not Found’, url=URL(β€˜http://localhost:5005/version’)

@NehaManglani can you share the screenshot? and share rasa version rasa --version

@nik202

@NehaManglani I guess you messed up with you conda environment, will able to create a new conda environment with python 3.8 and then install rasa and rasa-sdk 2.8.1 and then rasa x 0.39.3 as shown in my previous thread? and its fine you can used your current project.

@NehaManglani this all you doing on localhost?

Rasa Version : 2.8.1 Minimum Compatible Version: 2.8.0 Rasa SDK Version : 2.8.1 Rasa X Version : 0.39.3 Python Version : 3.8.11

yes @nik202

@NehaManglani did you created the conda environment ? or working on the powershell ?

created a new conda env and followed all above steps:

Rasa Version : 2.8.2 Minimum Compatible Version: 2.8.0 Rasa SDK Version : 2.8.1 Rasa X Version : 0.39.3 Python Version : 3.8.11

@nik202

@NehaManglani that port is in use close everything in terminal and run only rasa x, it happen on Mac, I guess you working on Mac.

@nik202, yes mac. I closed everything, checked the port is not being used and restarted everything and now I get a new error:

checking after clearing the DB.

@NehaManglan cool, new error

install this and run

pip install sanic-jwt==1.6.0

then delete .db file if you see alembic error ok and then run rasa x

6 Likes

Thank you so much @nik202 !! :slight_smile: It worked!!!

Consolidating the sequence of steps, for everyone’s benefit:

On a fresh Conda environment: pip install rasa==2.8.2 pip install rasa-sdk==2.8.1 pip install rasa-x==0.39.3 --extra-index-url https://pypi.rasa.com/simple pip3 install SQLAlchemy==1.3.22 pip install sanic-jwt==1.6.0

4 Likes

@NehaManglani Great congratulations finally!

2 Likes