Arrangement and display of messages on Rasa X UI

Thanks for the great work… just having a few comments on the Rasa X UI. I tried using Rasa X on chrome and firefox and…

  • At times some of the messages seem to be obscured (see screenshot below)

  • When one enters\adds a new message to a conversation, it will be great if the page that displays the conversation history is scrolled down automatically to display the new message that has just been added. I am having to scroll down each time…

Hey @SimbaM! Thanks for the feedback. We released an update of rasa x last night. I believe these issues were addressed, would you mind updating and letting us know if the issues still persist?

Issue Still persist for me.

Okay, that’s definitely a bug then. Would you mind creating a bug report on our GitHub:

Could you please let me know the fix of this issue.

@mayanknagpal when you say it still persists for you, you’ve updated to the latest version right?

@AnkitSingh21 if it doesn’t work on the latest version, then there is no fix yet, which is why i’d create a bug report.

@erohmensing I am new to this area. Could you explain how to update to the latest rasa x version.

You can update any pip packages by using the -U flag in the installation command, so in this case:

pip install -U rasa-x --extra-index-url

@erohmensing Got this error while trying to run the command

How did you install Rasa to begin with? Docker/pip?

I have installed it a few different ways, and are you running conda from a virtual environment? I am limited/new to all of this, but spent many many hours troubleshooting

@FelixKing We used pip to install Rasa x. Also we are not using anaconda for virtual environment.

Hey @AnkitSingh21

For the “Access Denied” error, you will need to make sure you run cmd as administrator. Let me know if it works for you


I use anaconda and managed to install it. I used

pip install rasa-x --extra-index-url

got this from the installation instructions

@SimbaM Hey this time i did not get the user error but still some errors are there.

hey @AnkitSingh21 can you try uninstalling rasa-x and install it again.

No i have not tried that option. Is there any other option which i can try ?

pip install rasa==1.9.5 --user

downgrading rasa version did the trick for me.