not updated in Ubuntu after editing

I am using local machine - Window 10 64bit, Ubuntu 18.04 LTS for running rasa. There is a typo in that open a file in a directory, which lead to no file found. So I made the changes and save it. After saving the file, i run action server using “rasa run actions”. However, the error still persist showing the typo still exist. Some info for you to know:

  1. The typo error is confirmed corrected by viewing the file using various code editing and text editing software.
  2. The typo only lead to wrong file, not wrong logic(“navigation.txt”->“naviagtion.txt”)
  3. I always ended the server using ctrl+c
  4. I restarted the computer and the error still persist.
  5. My pc and ubuntu does not have this problem when dealing with something similar. I usually would edit the code using code editor, save it, and run on Ubuntu for testing+debugging, so far nothing like this happened.
  6. I restarted Ubuntu still not working.

Does anyone have some solutions? Thanks

UPDATE: After around 1 hour, Ubuntu prompt me that I do not have permission on when I attempt to run again. After giving permission, everything is back to normal (edit in text editor, save it, and then run actions server works). This issue has occurred to me twice(including todays). Can anyone provided some insight so that I won’t face it again?

The error is solved by killing the process manually. Search the command using “ps aux | grep rasa”, and then kill it using process ID.