The suggestion from @laboratory worked for me - thanks Charles!
I did get this output, below, at the end, but it did not appear to cause me problems and this method was light years ahead of trying with the standard resolver in pip 21.0.1 (I had thought I’d give it a go but it was taking more an more time so I eventually gave up)
ERROR: pip’s legacy dependency resolver does not consider dependency conflicts when selecting packages. This behaviour is the source of the following dependency conflicts.
sanic-jwt 1.6.0 requires pyjwt==2.0.0, but you’ll have pyjwt 2.0.1 which is incompatible.
Successfully installed GitPython-3.1.14 Mako-1.1.4 MarkupSafe-1.1.1 alembic-1.4.3 attrs-19.3.0 croniter-1.0.10 gitdb-4.0.7 isodate-0.6.0 kafka-python-1.4.7 pika-1.2.0 python-editor-1.0.4 rasa-x-0.38.1 sanic-jwt-1.6.0 smmap-4.0.0 ujson-1.35
Might be worth a few people submitting their details via PyPI’s survey, as detailed in the pip output:
To improve how pip performs, tell us what happened here: https://pip.pypa.io/surveys/backtracking
I did it with my details but others confirming their similar details will underline that it’s not a one-off / user error, so PyPI can consider it. Of course there may be some narrowing down of the version requirements that could be done on the Rasa side too (I’m not 100% sure on this)